Neuron Install Guide

Deep Learning AMI

AWS Deep Learning AMI (DLAMI) is the recommended AMI to use with Neuron SDK, In addition to DLAMI Neuron SDK can be installed on Ubuntu or Amazon Linux using standard package managers (apt, yum, pip, and conda) to install and keep updates current, Neuron SDK is suppotred in DLAMI with Conda and in DLAMI Base , for more information see The AWS Inferentia Chip With DLAMI .

Note

Only Ubuntu 16,18 and Amazon Linux2 DLAMI are supported (Amazon Linux is not supported)

Only DLAMI versions 26.0 and newer have Neuron support included.

Neuron supports Python versions 3.5, 3.6, and 3.7.